vagrantを最新のvirtualboxで動かないのは割とよくある。

環境
vagrant:2.0
virtualbox:5.2

最近どかどかdockerに引き続きvagrantとかいじっちゃってる僕です。

vagrantでubuntuを作ろう!という感じで進めてましたがここでエラー。

vagrant

The provider virtualbox that was requested to back ~

なるほどー。

これは僕でもわかるエラーです。

virtualboxを5.13にしましょー。

virtualbox5.13

これでvagrant up –providr virtualboxが通るはずです。

エラーはちゃんと読まないといけませんね。